Compiler kde4 avec alsa

Je me suis bien pris la tête ce soir à essayer de compiler la version trunk de KDE (celle qui correspond à la version 4.2 qui va sortir au mois de janvier 2009). Pour la compilation de kdelibs, pas de soucis, j’avais toutes les bonnes librairies installées. Il a juste fallu installer aussi kdesupport (mais ça ne pose pas de problème, tout est expliqué sur http://techbase.kde.org). C’est au moment de compiler kdebase que les choses se sont gâtées. Impossible de le compiler car il me sort qu’il lui faut alsa 1.0.14 ou supérieur. Je regarde dans la liste de mes paquets (kubuntu intrepid), alsa est installé. Je cherche désespérément un paquet qui s’appellerait libalsa-dev, mais rien de tout ça. Il y a bien un libalsaplayer-dev, mais après installation de ce paquet, toujours pas bon !

Finalement, il faut installer le paquet libasound2-dev. Vous auriez deviné ? Moi non. J’ai trouvé le nom de la librairie en fouillant dans le fichier CMakeCache.txt ! Et effectivement, dans aptitude, on nous dit : Fichiers de développement de la bibliothèque ALSA. Super le choix du nom du paquet !

Bon, maintenant, c’est bon, ça compile. Je vais en avoir pour la nuit, mais normalement demain matin j’aurai un KDE4.2 tout neuf 🙂

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *