Comment contourner le bogue Plasma 5 sur Debian / Stretch

25 AUT 15
Comment contourner le bogue Plasma 5 sur Debian / Stretch
Catégories : KDE
plasma5_debianDepuis le 19 août 2015, Plasma 5 ne se lance plus du tout sur Debian / Stretch, l’actuelle version testing.  Les paquets libkdecorations2-5_5.3.2-1_amd64.deb et
libkdecorations2private5_5.3.2-1_amd64.deb seraient à incriminer. Le bogue a été confirmé sur bugs.debian.org.

Aujourd’hui (25 août 2015) le bogue persiste toujours. Voici comment le corriger temporairement.

L’idée est de revenir à une version antérieure du système en utilisant snapshot.debian.org. Pour cela, créez le fichier /etc/apt/preferences.d/snapshots contenant :

Créez ensuite le fichier /etc/apt/sources.list.d/snapshots.list et ajoutez-y le contenu :

puis lancez

Il est fort probable que vous obteniez un message d’erreur vous indiquant que le fichier « Release » a expiré, et que la mise à jour ne se fera pas. Dans ce cas, lancez les commandes apt-get (ou aptitude) avec l’option Acquire::Check-Valid-Until=false

Ne pas oublier de supprimer les fichiers /etc/apt/preferences.d/snapshots et /etc/apt/sources.list.d/snapshots.list quand tout sera rentré dans l’ordre 🙂

Sources

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *